Welcome to NESR! Most features of this site require registration, including replying to threads, sending private messages, starting new threads, and uploading files. Click here to register.

Results 1 to 5 of 5

'01 GS500 Signal Generator Problem, Help?

  1. #1
    Newbie
    Join Date
    Jun 2012
    Location
    Boston, MA
    Posts
    4

    '01 GS500 Signal Generator Problem, Help?

    So the other day I was riding when my bike started backfiring and died on me.

    I took off the signal generator cover and found that the bolt holding the signal rotor had come loose. Problem is, it had broke off right at the crankshaft, so now the rest of the bolt is still screwed in.
    '01 GS500 Signal Generator Problem, Help?-003-jpg
    '01 GS500 Signal Generator Problem, Help?-002-jpg

    I was thinking of getting some sort of bolt remover kit to try to get it out. And also getting a new signal generator assembly, this one looks pretty beat up with all the melted plastic.

    Any suggestions?

    Never done work like this before on a bike.

    0 Not allowed! Not allowed!

  2. #2
    Lifer Kurlon's Avatar
    Join Date
    Jun 2007
    Location
    Waterboro ME
    Age
    44
    Posts
    12,968

    Re: '01 GS500 Signal Generator Problem, Help?

    Get a set of left handed drill bits. Start with the smallest, work your way up till it backs out on it's own.

    1 Not allowed! Not allowed!

  3. #3
    Dictionary quoting knob stoinkythepig's Avatar
    Join Date
    Dec 2002
    Location
    Raymond NH
    Age
    56
    Posts
    4,662

    Re: '01 GS500 Signal Generator Problem, Help?

    You'll want to be sure it's not a reverse thread before you drill it with reverse bits... Considering the crank rotates clockwise in that pic, it might be a reverse thread.

    0 Not allowed! Not allowed!

  4. #4
    Dictionary quoting knob stoinkythepig's Avatar
    Join Date
    Dec 2002
    Location
    Raymond NH
    Age
    56
    Posts
    4,662

    Re: '01 GS500 Signal Generator Problem, Help?

    I did a little research, looks like it's a normal M6x1 thread on that bolt.

    0 Not allowed! Not allowed!

  5. #5
    Lifer Kurlon's Avatar
    Join Date
    Jun 2007
    Location
    Waterboro ME
    Age
    44
    Posts
    12,968

    Re: '01 GS500 Signal Generator Problem, Help?

    Quote Originally Posted by stoinkythepig View Post
    I did a little research, looks like it's a normal M6x1 thread on that bolt.
    That matches my memory, I didn't remember it being reverse thread but couldn't recall for certain.

    0 Not allowed! Not allowed!

Similar Threads

  1. Why you signal big when slowing down on track
    By fromario in forum General Bike Related
    Replies: 16
    Last Post: 06-21-14, 12:47 AM
  2. Turn signal requirements in MA
    By Garandman in forum General Bike Related
    Replies: 11
    Last Post: 10-13-10, 09:50 AM
  3. How do you signal that there's fuzz around?
    By number9 in forum General Bike Related
    Replies: 51
    Last Post: 04-23-09, 09:10 AM
  4. Turn signal woes
    By Zolden in forum Bike Maintenance
    Replies: 7
    Last Post: 06-05-08, 09:18 AM
  5. LED turn signal wiring?????
    By NEWTREADS in forum Bike Maintenance
    Replies: 4
    Last Post: 10-14-07, 05:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •